Wordpress släpper en ny uppdatering 7 maj 2019. Den nya uppdateringen är version 5.2 och kommer att ställa krav som kan drabba tusentals hemsidor. Det är nämligen så att den nya versionen av WordPress kräver minimum PHP version 5.6.20. Om man inte använder den godkända PHP versionen så kan man inte heller uppdatera WordPress, vilket man kontinuerligt borde göra. Om du har ett serviceavtal med oss så kan du sluta läsa här.

Du kan alltså inte uppdatera WordPress

utan att ha höjt PHP versionen till 5.6.20

Vad ska man göra?

Om du är osäker på vilken PHP version du använder idag så kan kan du antingen kolla detta i din cPanel eller i din WordPresspanel. Om du ser en notis i panelen med rubriken ”En uppdatering av PHP krävs” så har WordPress upptäckt att din webbplats använder en utdaterad version av PHP. Då bör du genast uppdatera till en nyare version.

Om din webbplats är kontinuerligt underhållen och up-to-date så räcker det oftast med att ändra din version av PHP på ditt webbhotellkonto via cPanelen. Det gör du genom att logga in på cPanelen, leta efter rubriken ”Programvara” och klicka på Select PHP Version. Här kan du se vilken version du använder och du kan uppdatera till en ny standard.

Om du däremot har en webbplats som du inte uppdaterar, det kanske finns gamla tillägg eller en hosting utan cPanel så kan det bli svettigt. Du kan även behöva byta ut tillägg och teman som är kompatibla med en nyare version av PHP. Innan man gör större ändringar är det extremt viktigt att ta en backup för att minska risken för krasch.

Om du inte har kunskapen av kodning och felsökning så rekommenderar vi att du tar hjälp. Glöm inte att vi erbjuder prisvärda serviceavtal så att du slipper tänka på uppdateringar som dessa. Det finns en stor chans att WordPress skärper PHP kravet ytterligare till version 7.0 under året.

Kan man låta bli att uppdatera WordPress?

WordPress är ett CMS som inte uppdateras i onödan. Dvs, du bör alltid uppdatera WordPress, teman och tillägg för att ta del av alla prestandaförbättringar och säkerhetsfixar. Om man inte uppdaterar så finns det stor risk att webbplatsen blir långsam och osäker. Med osäker menar vi att den kan bli hackad genom olika kryphål som uppstår vid utdaterad kod. Alla moderna teman och tillägg kommer samtidigt att kräva en modern version av PHP vilket betyder att webbplatsen kommer att krascha förr eller senare på ett eller annat sätt om du låter bli att uppdatera din PHP version.

Lämna en kommentar